it-swarm-ko.tech

이클립스를 시작할 수 없습니다

나는 꽤 오랫동안 Eclipse를 사용 해왔다. 방금 OpenJDK에서 SunJDK로 전환했습니다. 나는 이클립스를 사용하여 돌아 갔는데 잘 열렸다. 프로젝트의 빌드 경로에 라이브러리를 추가했지만 오류 검사기는 여전히 라이브러리가 없다고 말하고있었습니다. 그래서 나는 이클립스를 다시 시작하기로 결정했다. 이클립스를 시작할 수 없습니다. 오류나 아무것도주지 않습니다. 명령 줄에서 시작하면 아무것도하지 않습니다.

[email protected]:~$ Eclipse
[email protected]:~$ 

워크 벤치 선택 대화 상자 나 그 어떤 것도 팝업되지 않습니다. 아무도 들어 본 적이 있습니까? 우분투 저장소의 최신 버전을 사용하고 있습니다.

컴퓨터를 다시 시작하고 Eclipse를 다시 설치하려고했습니다. 아무것도.

4
Joel

나는 apt-get purge Eclipse를 사용한 다음 apt-get install Eclipse를 사용했지만 여전히 똑같은 일을했다. Sun JDK를 제거하고 Eclipse를 다시 설치하고 OpenJDK를 설치했습니다. 모든 것이 다시 작동합니다.

그러나 Sun JDK와 함께 작동하지 않는다는 것에 약간 실망했습니다. 오 잘 도대체 무엇이.

4
Joel

충분한 이유가 없다면 Eclipse를 실행하는 가장 좋은 방법은 Eclipse.org에서 다운로드하고 Ubuntu 리포지토리에 설치하지 않는 것입니다. 저장소 버전을 설치 제거하고 수동으로 다운로드하여 실행하십시오.

workspace/.metadata/.plugins/org.Eclipse.ui.workbench/log에 귀하의 경우에는 효과가 없을 것이라고 생각하지만 확인할 수있는 로그가 있습니다. 또한 이클립스를 다시 설치했다는 것은 무엇을 의미합니까? 시냅스를 사용하거나 디렉토리에 압축을 풀고 있습니까? which Eclipse 실행중인 시스템을 확인하기 위해 많은 버전을 설치 한 경우.

eclipse.ini에서 -vm 매개 변수를 사용하여 JRE를 수동으로 설정하는지 변경하십시오.

0
ilcavero