it-swarm-ko.tech

iPod Touch (iPhone) 용 펌웨어 업데이트?

Ubuntu에서 iPod Touch (iPhone)의 펌웨어를 업데이트해야합니다. iPod Touch를 탈옥 한 상태에서 앱을 설치하려면 iTunes가 필요하지만, 불행히도 우분투에서는 아직 그렇게 할 방법을 찾지 못했습니다. VirtualBox 또는 Wine을 사용할 수는 있지만 iTunes가 대부분의 경우 Wine 그리고 VirtualBox의 경우 몇 개월 전에 우분투로 전환 한 Windows를 다시 설치해야하며 다시 돌아가고 싶지 않습니다.

이 경우 iPod Touch (iPhone)가있는 Linux 사용자는 무엇을합니까?

문제를 해결하기위한 제안은 기뻐할 것입니다.

마지막으로, Apple이 Linux OS 용 iTunes를 개발하기까지 얼마나 걸립니까?

18
Bakhtiyor

일부 이전 버전의 iTunes는 현재 Wine (또는 Crossover)과 작동하도록 만들 수 있지만, 새로운 iPod을 업데이트하거나 동기화하는 데 사용할 수 없습니다

Wine에 Windows USB 장치 드라이버에 대한 처리기가없고 iPod이 사용자 지정 USB 장치로 작동하기 때문입니다. 이것은 특별한 키 동글이 필요한 소프트웨어가 아직 와인에서 작동하지 않는 것과 같은 이유입니다. 여기에는 몇 가지 예비 패치가 있으며 Wine wiki 에서 더 많은 기록을 읽을 수 있지만 아무런 효과가 없을 것으로 예상됩니다.

현재 Wine에서 작동하는 유일한 iPod은 단순한 USB 대용량 저장 장치 역할을하는 구형 iPod입니다. 그럼에도 불구하고 여전히 오래되고 작동하는 iTunes를 찾아야합니다.

Wine에서이 문제로 인해 펌웨어 업그레이드를 수행하려면 Virtualbox 또는 VMware를 사용하여 가상 머신을 설정하거나 다른 사람의 컴퓨터를 빌려야합니다.

9
Scott Ritchie

이것이 iPod touch에서 작동하는지 모르겠지만 이전 iPod에서는 작동합니다. http://code.google.com/p/iPod-update/

4
manyxcxi

CrossoveriTunes 용 페이지 를 보면 몇 가지 버전이 다소 작동하는 것으로보고되었습니다. 크로스 오버는 돈이 들지만 그만한 가치가 있습니다.

3
Michael Crenshaw

펌웨어 업그레이드가 작동하지 않습니다. vmplayer가있는 Ubuntu 8.04 LTS와 iTunes가있는 오래된 XP.

기회 없음. 내 업무 측면에서 내 Windows PC에 연결하기 전까지는 하루 종일 iPhone이 고장났습니다.

이 관점에서 : Apple 제품은 절대로 No-Go입니다! 전화를 받기 위해 iTunes와 함께 Windows 나 Mac이 필요한 이유는 무엇입니까? '매직 한 것'을 구입할 때 제대로 작동하려면 iTunes를 실행해야한다고되어 있습니까? 이전의 비용을 누가 알고 있습니까?

3
Ice

libimobiledevice

아직 실험 중이지만 libimobiledevice 를 확인해야합니다. 아직 GUI는 없지만 소프트웨어 (업그레이드 및 다운 그레이드 포함)를 포함하여 Linux에서 iPod touch 모델을 작동 시키려고 노력하고 있습니다.


편집 : buntu Wiki 에 따르면 이것은 최소 14.04 이후 기본값이며 다양한 프로젝트에서 구현됩니다. 자세한 내용은 libimobiledevice 프로젝트 페이지에서 뉴스와 상태를 확인하십시오. 현재 그들은 작성 당시 베타 버전 인 iOS 9를 지원한다고 주장합니다.

2
PierreS

VMware에서 실행되는 iTunes를 사용하여 iPhone 펌웨어 양식 v2를 v3로 업데이트하는 데 지쳤습니다. 프로세스가 스트림 중반에 중단되었고 iPhone은 쓸모 없게되었습니다. 나는 그것을 친구의 Windows 컴퓨터에 연결했고 몇 번의 업데이트 시도 후에 다시 살아났습니다.

동일한 메이저 버전을 사용한 업데이트는 iTunes/VMware에서 잘 작동했습니다.

0
A.B.